¡Qt 5 ya está aquí! (Bueno, no…)

… digamos que CASI está aquí. Han liberado la primera beta hoy mismo, y el lanzamiento oficial y definitivo está previsto para Noviembre; seguramente, veamos muchas otras betas hasta entonces.

Lo malo es que, desde hace algún tiempo ya, el compilador que se utiliza por defecto para Qt en Windows es el MVC… ¡y a mí no me gusta! Vale, se sigue pudiendo instalar y compilar Qt con MinGW, pero en QtLabs dicen que no todos los módulos funcionarán con ese compilador. ¿Es un defecto a corregir en siguientes versiones, ya que a fin de cuentas es una beta? ¿O tal vez sea indicativo de un cambio de política por parte de los desarrolladores? No tengo ni idea, pero me da un poco de pereza el cambiar de compilador… en fin.

Por ahora, he descargado la beta. No la he instalado todavía porque tengo miedo de que interfiera con la versión existente, la 4.8.0. Generalmente no ocurre así, pero eso es cuando se trata de una versión compatible y que no es una beta… ¡y que utiliza el mismo compilador! Para colmo, la versión que tengo instalada de MinGW / g++ es la 4.4, y de nuevo en QtLabs se menciona la necesidad de una 4.6 mínima… así que ni siquiera me atrevo a sacar el paquete de código fuente e intentar instalar y compilar por mi cuenta. ¡Maldición, con las ganas que tengo de empezar a probar con Qt 5! Hay cambios bastante grandes en cuanto a sintaxis (ha cambiado el paradigma de señales y slots), y no quiero quedarme descolgado cuando lleguen.

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s